Montage und Test

Hier ist die Montagebeschreibung der Entwickler:

http://ftp.openvario.org/Open%20Vario%20Assembly%20Guide.pdf

Diese sollte präzise befolgt werden.

Die wichtigsten Schritte:

  1. 12 V an das Adapterboard anschließen (Mitte des dreipoligen Sockels ist Minus, zunächst genügt es Plus an den ersten Kontakt anzuschließen. Soll auch das RJ45 Board getestet werden, so muss auch der dritte Kontakt angeschlossen werden. Eine Brücke zwischen erstem und dritten Kontakt tut es auch)
  2. am Ausgang des DC-Wandlers (die kleine aufgelötete Platine) müssen 5 V zu messen sein
  3. am Ausgang des Spannungsreglers 2940 müssen 3.3 V zu messen sein. Dies ist das dritte Beinchen des Reglers, von rechts gesehen (siehe Bild). Diese 3.3 V müssen auch an der unteren Jumperreihe (JMP1, JMP2, JMP3) zu messen sein.

Wenn alles gut aussieht, geht es an das Zusammenstecken:

  1. Stromversorgung abschalten
  2. die Stromversorgung des Cubieboards wie im obigen Dokument beschrieben verbinden
  3. die RX/TX Pins von Adapterboard und Cubieboard wie beschrieben verbinden
  4. das Cubieboard passgenau auf die beiden Sockelleisten stecken
  5. das 30polige Displaykabel in den Sockel auf dem Adapterboard einführen (mit Kontaktseite nach oben!) und verriegeln
  6. das Displaykabel in den Sockel des Displays einführen (mit Kontaktseite nach unten, also zum Display gerichtet!) und verriegeln
  7. noch einmal prüfen, dass keine metallischen Gegenstände (abgeschnittene Drähte, …) auf dem Tisch unter dem Aufbau liegen!
  8. Stromversorgung einschalten!
  9. Und oh Wunder: nach einigen Sekunden erscheint der XCSoar Startbildschirm!

first_light

Zunächst war ich ein wenig enttäuscht von dem nicht sehr hohen Kontrast unter meiner Laborlampe. Auch die XCSoar-Konfiguration ist mir noch fremd, bisher bin ich mit Cumulus geflogen. Das ist noch ein Lernprozess. Aber: ES LEBT!  🙂

Der schwache Kontrast und die fehlenden Farben liegen offenbar an einem Fehler meines Displays, der Sockel für die Hintergrundbeleuchtung ist fehlerhaft. Das Problem versuche ich zu lösen.

Aber mit halbwegs funktionierender Hintergrundbeleuchtung und installierten Karten sieht es so aus:

second_light

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.